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Welcome to Excel Online 
Excel when and where you need it. Easily discover, visualize, and share insights from your data. 

To Access Office 365 open a web browser (Internet Explorer, FireFox, Chrome or any other Web 
Browser). Enter http://portal.microsoftonline.com 

 

 

Enter your E-Mail Address and your Office 365 password and click sign in. 

 
Select Excel Online 
  

http://portal.microsoftonline.com/
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Create a document from OneDrive for Business 

You can create new Office documents directly from OneDrive for Business. 

Not sure where to create your document? See Should I save my documents to OneDrive for Business or 
a team site? 

1. Sign in to Office 365 with your work or school account at http://portal.office.com. For example, 
ellen@mednax.com. If you're not sure what your work account is, check the welcome email 
message that asked you to sign in the first time.  

2. At the top of the page, select the app launcher , and then select OneDrive. 

               
Click New, and then choose the type of document you want to create. 

 

The new document opens in the Office Online program you selected. For example, selecting 

Excel document opens Excel Online. 

Tip   There's no save button, because the document is saved for you automatically. 

1. To rename the document, click its name in the title bar, type the new name you want, and then 
press ENTER. 

https://support.office.com/en-us/article/Should-I-save-my-documents-to-OneDrive-for-Business-or-a-team-site-d18d21a0-1f9f-4f6c-ac45-d52afa0a4a2e
https://support.office.com/en-us/article/Should-I-save-my-documents-to-OneDrive-for-Business-or-a-team-site-d18d21a0-1f9f-4f6c-ac45-d52afa0a4a2e
http://portal.office.com/
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2. When you’re done and you want to go back to where the file is saved, click your name, next to 
the file name. 

(Or, click the back button in your browser to go back to where your document is saved. If you 
click Back, click refresh to see your new document in the file list.) 

Tip    If you want access to all app features, you can switch to the full Office app. For example, in Excel 
Online, click Open in Excel to continue working on the document in Excel. 

 

Create a document from an Office desktop app 

You can also start in an Office desktop app, such as Word, Excel, or PowerPoint, and create and save a 
document straight to OneDrive for Business. 

1. Start a document as usual in an Office desktop app (File > New, and pick a template). 
2. When you're ready to save the document, click File > Save As > OneDrive - 

YourCompanyName. For example, OneDrive - Contoso. 
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3. Give the file a name, and then click Save. 

Tips   If you don't see OneDrive - YourCompanyName, click Add a Place > Office 365 SharePoint. Then 
sign in to Office 365 with your work or school account. 

 

Once you add OneDrive for Business as a place in one Office app, you can save files from all your Office 
apps. 

If you’re signed in to Office 365, and your subscription includes Office, you can install the latest version 

of the desktop apps. At the top of the page in Office 365, go to Settings > Office 365 Settings > 
Software. 
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Basic tasks in Excel Online 
Create an online workbook 

1. From your OneDrive, click New > Excel workbook. 

 

2. To rename the workbook, click the default file name and type a new one. 

 

  



 
 

 
Champion Solutions Group • 791 Park of Commerce Blvd., Suite 

200 Boca Raton, FL 33487 Phone:  877-788-1617 ∣ 561-997-2900 | 

| www.championsg.com | www.messageops.com |  

 

Share workbooks online 

To share a workbook, click Share and type email addresses of people you want to share with or get a 
link you can email to your contacts. 

 

Edit in the browser 

If you try to enter data, set up a formula, add charts, or apply basic formatting and nothing happens, 
you’re probably in read-only view. Here's how you can switch to editing view: 

Click Edit Workbook > Edit in Excel Online. 

For more advanced editing options, click Edit in Excel. 

Excel Online saves your work automatically however, if you change your mind about any changes 
you’ve just made, use Undo or press Ctrl+Z. 

Work together on the same worksheet 

When you’re working with others in Excel Online, you can edit the worksheet as you usually would. 
When others edit the worksheet, Excel Online shows their presence and the updates right away. This 
only works when everyone is working in Excel Online. If anyone opens the workbook in Excel desktop, 
others won't be able to edit the workbook at the same time in Excel Online. 
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Top tips for working in Excel Online 

Copy and Paste in Excel Online 

A simple thing like copy and paste might have you flummoxed in a browser-based program. You can 
copy and paste text, but only if you use keyboard shortcuts. And text you copied outside of Excel 
Online will probably be pasted as plain text, which means that formatting (things like bold, italics, and 
hyperlinks) needs to be re-applied. For best results, use keyboard shortcuts, not the right-click menu or 
Clipboard commands in Excel Online. Press CTRL+C to copy, CTRL+X to cut, or CTRL+V to paste the text 
(Windows); or press ⌘+C, ⌘+X, or ⌘+V (Mac). If paste isn’t working, you’re probably looking at 
Reading view. Switch to Editing view: Go to Edit Workbook > Edit in Excel Online. 

Reapply formatting  

To reapply text formatting like bold or italics, select the text you pasted, click Home, and then click the 
formatting you want. If you’re pasting a hyperlink, you’ll have to reconstruct it: 

1. Right-click the cell, and then click Hyperlink. 
2. In the Display Text box, type text you want to show in the cell. 
3. In the URL box, type the web address of the link (URL). 

Format numbers 

When you type numbers in your worksheet, Excel Online automatically applies the General number 
format but you can change this to show specific number formats like dates, currency, or even fractions.  

For example, if you’re working on your quarterly budget, you can use the Currency number format to 
show your numbers as monetary values. You can set dates to display either as a long date like 
Saturday, December 14, 2013 or a short date 12/14/13. Here’s how: 

1. Select the column, or cells you want to format. 
2. Click Number Format and pick the format you want. 

Print in Excel Online 

1. Select the cells or chart you want to print, and then go to File > Print. To print the whole 
worksheet, don’t select anything before going to the Print command. 

https://support.office.com/en-us/article/show-specific-number-formats-bb5681af-ac43-4682-be14-89e9d7d899ee
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2. Click Print for a preview. 
3. If you change your mind about printing a selected area, choose the Entire Sheet print option 

and click Print. 
4. If the final print preview looks right, click Print. 

 

Integrate seamlessly with Excel 

You create a workbook in Microsoft Excel. You want to post it on a website so that other people can 
interact with the live data, maybe even enter some data. What if you want to collaborate with 
someone who has a different version of Excel than you do? Wouldn't it be great if you could work on it 
together, right there on the website? Excel Web App makes this scenario possible. 

In Microsoft Excel 2016 you can start using Excel Web App by saving your workbook to your OneDrive. 
On the File tab, click Save As, and then click OneDrive - YourCompanyName. 
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Now, your workbook is available to view and edit in the browser, or re-open in Excel.  

Note    Workbooks don’t have to be created in Excel 2010 to be opened in Excel Web App. For best 
compatibility, use Office Excel 2003 or later, or use Excel for Mac 2008 version 12.2.9 or Excel for Mac 
2011. If you’re using Excel 2003, install the most recent service pack and save workbooks on your 
computer as .xlsx files. Then upload the workbook to a SharePoint site where Office Web Apps 
programs are configured. 

View a workbook in the browser 

When you open your workbook in SharePoint, Excel Web App opens the workbook in the browser, 
where you can move around the workbook, sort, filter, expand and collapse PivotTables, and even 
recalculate the workbook. 
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You can also use the Find command to search for words or phrases. As with a web page, you can select 
content on a worksheet and copy it so that it's available to paste in another application.  

Edit in the browser 

If you want to make changes in the workbook, click Edit in Browser to change data, enter or edit 
formulas, and apply basic formatting.  

 

In Editing view, you can type and format text as usual, and you can use cut, copy, paste and undo/redo 
commands. Enter a formula by going to the cell where you want to enter the formula, typing an equal-
sign (=), and then typing the formula or function. 

You can also add tables and hyperlinks. Go to the Insert tab to add these. If you want to add a chart, 
select the range of cells to be charted, and then go to the Insert tab and select the type of chart you 
want. 

Excel Web App saves your workbook automatically while you work on it. You don’t have to save your 
changes. If you make changes that you don't want to keep, use the Undo command or press CTRL+Z 
(Windows) or ⌘+Z (Mac).  

Work with other people 

If you make your workbook available for other people to edit, your friends or colleagues can work on 
the workbook at the same time as you. This works well for workbooks where you are collecting 
information from a group of people, such as a list of information or a group project. No more e-mailing 
a list around or waiting for your teammate to check it back in on the server.  
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While you are editing the workbook, Excel Web App shows you whether other people are also working 
on the workbook.  

1. Store the workbook on a website where your colleagues can access it, such as your team's 
SharePoint library.  

2. Invite other people to work on the workbook. 
3. In SharePoint, copy the web address of the workbook that appears in the browser and then 

paste the web address into a message. 
4. Edit the workbook in Excel Web App. You are able to see who else is working with you in the 

status bar. 
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Excel Web App at a glance 
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1. In the browser view of a workbook, you can navigate through the workbook, sort, filter, expand and 
collapse PivotTables, and even recalculate the workbook. 

2. The data you are viewing is live. You can refresh a PivotTable, or refresh the whole workbook. 

3. Click Edit in Browser to edit the workbook in the browser; click Open in Excel to work on it in the 
Excel desktop application. 

4. When you edit the workbook in your browser, you can enter data and formulas, create tables and 
charts, and do some formatting. To enter formulas, type equal-sign (=), and then the formula or 
function. For help with Excel functions, see the Excel functions (by category). 

5. Excel Web App has the look and feel of Excel. 

 Click the File tab to save a copy of the workbook or download a snapshot that contains just 
values and formatting, no live data. 

 The Home tab has commands for formatting text and cells, adding rows and columns, and 
recalculating data. 

 Use the Insert tab to add charts, tables and hyperlinks to your worksheets. 
 Excel Web App saves your work automatically. Use Undo to get rid of changes you don't want 

to keep.  

6. If other people are working on the workbook, you can see who they are by clicking in the bottom 
right corner of the browser window. 

https://support.office.com/en-us/article/Excel-functions-by-category-5f91f4e9-7b42-46d2-9bd1-63f26a86c0eb

